summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:33 +0200
commit33d847e6ec568c8f3e2a8c3d95640b1556cce1dc (patch)
tree2bca4bbc96d2e785292d1e512f8cb56b2ee7ac84
parent9ad7cc6404f228e3d624a7151f70d2c6b0a36eea (diff)
downloadguix-33d847e6ec568c8f3e2a8c3d95640b1556cce1dc.tar.gz
gnu: Add texlive-svninfo.
* gnu/packages/tex.scm (texlive-svninfo): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a4ddf33d18..abba1ee0d3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96899,6 +96899,25 @@ is well supported.  The package interacts with an external Perl script, to
 retrieve information necessary for the required output.")
     (license license:lppl)))
 
+(define-public texlive-svninfo
+  (package
+    (name "texlive-svninfo")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/svninfo/" "source/latex/svninfo/"
+                   "tex/latex/svninfo/")
+             (base32
+              "0y0lxpp1lqznvsxvckhcnvw3l712l9prfb9gi56csypngaqph5rb")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/svninfo")
+    (synopsis "Typeset Subversion keywords")
+    (description
+     "This is a package for incorporating the values of Subversion keywords into
+typeset documents.")
+    (license license:lppl1.0+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar