summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:40:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:52 +0200
commit342800f747e7675144568aed19039dbacc639ed4 (patch)
treecd79c4505d67ae51d7616b19436e08d18e06553f
parentada78c49fec8993334d3af847cfe1cda6bf23ea5 (diff)
downloadguix-342800f747e7675144568aed19039dbacc639ed4.tar.gz
gnu: texlive-ms: Refresh package definition.
* gnu/packages/tex.scm (texlive-ms): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm43
1 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e6df23be0e..562974b8bc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9148,28 +9148,27 @@ and back-ends.  It also ensures compatibility with the @code{media9} and
 (define-deprecated-package texlive-latex-ocgx2 texlive-ocgx2)
 
 (define-public texlive-ms
-  (let ((template
-         (simple-texlive-package
-          "texlive-ms"
-          (list "doc/latex/ms/" "source/latex/ms/" "tex/latex/ms/")
-          (base32 "1cgrpx5mybiirjjdmni8kvqdg37dwfkixq3h9ami0mgxqqqfl2x3"))))
-    (package
-      (inherit template)
-      (outputs '("out" "doc"))
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "latex/ms")
-         ((#:tex-format _ "latex") "latex")
-         ((#:build-targets _ '())
-          #~(list "count1to.ins" "multitoc.ins"))))
-      (home-page "https://ctan.org/macros/latex/contrib/ms")
-      (synopsis "Various LaTeX packages by Martin Schroder")
-      (description
-       "The remains of a bundle of LaTeX packages by Martin Schroder; the
-collection comprises: count1to, make use of TeX counters; and multitoc,
-typeset the table of contents in multiple columns.")
-      (license license:lppl))))
+  (package
+    (name "texlive-ms")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ms/" "source/latex/ms/"
+                   "tex/latex/ms/")
+             (base32
+              "1cgrpx5mybiirjjdmni8kvqdg37dwfkixq3h9ami0mgxqqqfl2x3")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:tex-format "latex"))
+    (propagated-inputs
+     (list texlive-everyshi texlive-tools))
+    (home-page "https://ctan.org/pkg/ms")
+    (synopsis "Various LaTeX packages by Martin Schroder")
+    (description
+     "This package is the remains of a bundle of LaTeX packages by Martin
+Schroder; the collection comprises: @code{count1to}, make use of TeX counters;
+and @code{multitoc}, typeset the table of contents in multiple columns.")
+    (license license:lppl)))
 
 (define-deprecated-package texlive-latex-ms texlive-ms)