summary refs log tree commit diff
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2022-06-18 17:04:12 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-22 23:11:50 +0200
commit344ac798739a8a608ad55a62d344092c3b5e46ca (patch)
tree6f4d60c30c83c92bb7b1c2e592a5c71a17139f6b
parent1635d39c3c7ea7ee26c6f98d662fb90e8e7fca35 (diff)
downloadguix-344ac798739a8a608ad55a62d344092c3b5e46ca.tar.gz
gnu: sent: Add farbfeld to propagated-inputs.
* gnu/packages/suckless.scm (sent)[propagated-inputs]: Add it.
[phases]{patch-farbfeld}: New phase.
[inputs]: Add farbfeld.
[home-page]: Add trailing slash to fix linter warning.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/suckless.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 0607e8f84e..f5eb8b43f5 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -520,7 +520,11 @@ point surf to another URI by setting its XProperties.")
     (build-system gnu-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
-                  (delete 'configure))  ; no configuration
+                  (delete 'configure)  ; no configuration
+                  (add-before 'build 'patch-farbfeld
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (substitute* "config.def.h"
+                        (("2ff") (search-input-file inputs "/bin/2ff"))))))
        #:tests? #f                      ; no test suite
        #:make-flags
        (let ((pkg-config (lambda (flag)
@@ -534,7 +538,8 @@ point surf to another URI by setting its XProperties.")
     (native-inputs
      (list pkg-config))
     (inputs
-     `(("libpng" ,libpng)
+     `(("farbfeld" ,farbfeld)
+       ("libpng" ,libpng)
        ("libx11" ,libx11)
        ("libxft" ,libxft)
        ("fontconfig" ,fontconfig)))
@@ -544,7 +549,7 @@ presentations.  Each paragraph represents a slide in the presentation.
 Especially for presentations using the Takahashi method this is very nice and
 allows you to write down the presentation for a quick lightning talk within a
 few minutes.")
-    (home-page "https://tools.suckless.org/sent")
+    (home-page "https://tools.suckless.org/sent/")
     (license license:x11)))
 
 (define-public wmname