summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-23 17:12:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-12-10 20:24:11 +0200
commit358c3d612b00f58f713746b7ec6ca11c7b03875e (patch)
treeebec781813bbc90c7e602af6522183c07c4cb051
parente522d84035ba22e536b3ed2141f7c2062cfab6eb (diff)
downloadguix-358c3d612b00f58f713746b7ec6ca11c7b03875e.tar.gz
gnu: Add python-pytest-cov.
* gnu/packages/python.scm (python-pytest-cov, python2-pytest-cov): New
variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index afc9dcd6a2..91c9328230 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1633,6 +1633,34 @@ and many external plugins.")
 (define-public python2-pytest
   (package-with-python2 python-pytest))
 
+(define-public python-pytest-cov
+  (package
+    (name "python-pytest-cov")
+    (version "2.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pytest-cov" version))
+        (sha256
+          (base32
+           "1lf9jsmhqk5nc4w3kzwglmdzjvmi7ajvrsnwv826j3bn0wzx8c92"))))
+  (build-system python-build-system)
+  (propagated-inputs
+   `(("python-coverage" ,python-coverage)
+     ("python-pytest" ,python-pytest)))
+  (native-inputs
+   `(("python-setuptools" ,python-setuptools)))
+  (home-page "https://github.com/pytest-dev/pytest-cov")
+  (synopsis "Pytest plugin for measuring coverage")
+  (description
+   "Pytest-cov produces coverage reports.  It supports centralised testing and
+distributed testing in both load and each modes.  It also supports coverage
+of subprocesses.")
+  (license license:expat)))
+
+(define-public python2-pytest-cov
+  (package-with-python2 python-pytest-cov))
+
 (define-public python-pytest-runner
   (package
     (name "python-pytest-runner")