summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:21:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:37 +0200
commit365cec9a4852d2d8a900c75d56456612a78fc38e (patch)
tree703122f368c69b02b540ae11889a3c96fc03825f
parent03bce78042881185e27a8efe072e9750a820f410 (diff)
downloadguix-365cec9a4852d2d8a900c75d56456612a78fc38e.tar.gz
gnu: Add texlive-pst-hsb.
* gnu/packages/tex.scm (texlive-pst-hsb): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6f2d55a2c0..768fa67e41 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33214,6 +33214,26 @@ the graphics bundle's (original) @code{keyval} package, which clashes with
 PSTricks use of @code{xkeyval}.")
     (license license:lppl)))
 
+(define-public texlive-pst-hsb
+  (package
+    (name "texlive-pst-hsb")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-hsb/"
+                   "tex/generic/pst-hsb/" "tex/latex/pst-hsb/")
+             (base32
+              "0cv81bbkg2yhszjs2y7b5vs241y272by5mcb7adg347jzyrs8s74")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-hsb")
+    (synopsis "Curves with continuous colours")
+    (description
+     "This is a PSTricks-related package.  It can plot lines and/or curves
+with continuous colours.  Only colours defined in the HSB model are
+supported.")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")