summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 00:29:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:38 +0200
commit36e77dbd2a30edc8096b22dd692d3d62424ea50a (patch)
tree920fd2ef15262282028309a3e766fb2a1bc3c593
parentb42e997e85967f4da18822c221d4dd176a728b63 (diff)
downloadguix-36e77dbd2a30edc8096b22dd692d3d62424ea50a.tar.gz
gnu: texlive-latex-newfloat -> texlive-newfloat.
* gnu/packages/tex.scm (texlive-newfloat): New variable.
(texlive-latex-newfloat): Deprecate variable.
(texlive-minted): Use new name.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 17 insertions, 9 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 56c2ceafc9..71696fe6e5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5376,15 +5376,21 @@ compatible with @code{natbib}.")
 
 (define-deprecated-package texlive-latex-natbib texlive-natbib)
 
-(define-public texlive-latex-newfloat
+(define-public texlive-newfloat
   (package
-    (inherit (simple-texlive-package
-              "texlive-latex-newfloat"
-              (list "doc/latex/newfloat/"
-                    "tex/latex/newfloat/")
-              (base32 "1047max3li9ni15njgsvc7qglakgrjy2l0s72imgzdmwgb2h8jyf")
-              #:trivial? #t))
+    (name "texlive-newfloat")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/newfloat/"
+                   "source/latex/newfloat/"
+                   "tex/latex/newfloat/")
+             (base32
+              "1hrackdfrzad8cgbl3f3yaagk4p4zjbvq710rm8b1z02fr9z2zkq")))
+    (outputs '("out" "doc"))
     (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-graphics))
     (home-page "https://ctan.org/pkg/newfloat")
     (synopsis "Define new floating environments")
     (description
@@ -5393,6 +5399,8 @@ which the user may use to define new floating environments which behave like
 the LaTeX standard foating environments @code{figure} and @code{table}.")
     (license license:lppl)))
 
+(define-deprecated-package texlive-latex-newfloat texlive-newfloat)
+
 (define-public texlive-latex-newunicodechar
   (package
     (inherit (simple-texlive-package
@@ -10668,12 +10676,12 @@ configuration of its own fixed names, using @file{.mld} files.")
       (propagated-inputs (list python-pygments
                                texlive-etoolbox
                                texlive-fancyvrb
-                               texlive-fvextra
                                texlive-latex-float
                                texlive-latex-framed
+                               texlive-fvextra
                                texlive-ifplatform
-                               texlive-latex-newfloat
                                texlive-lineno
+                               texlive-newfloat
                                texlive-xstring))
       (home-page "https://ctan.org/pkg/minted")
       (synopsis "Highlight source code in LaTeX documents")