summary refs log tree commit diff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2024-01-04 09:16:49 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-01-22 00:20:49 +0100
commit37cbd7a27c490e82d88fad22aaa6cf373cec19ca (patch)
tree513f903e06c22f93cdf209432a23bdd2dd201ba4
parenta6ba98f1dae31ae094c31616927b1b3f45b18899 (diff)
downloadguix-37cbd7a27c490e82d88fad22aaa6cf373cec19ca.tar.gz
gnu: Add emacs-golden-ratio.
* gnu/packages/emacs-xyz.scm (emacs-golden-ratio): New variable.

Change-Id: I44de02989b8dadd4a395374fe078d4255a210028
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f4438f1bc8..f52756de19 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1376,6 +1376,30 @@ some utility functions, and commands using that infrastructure.")
 its mode line.")
       (license license:gpl3+))))
 
+(define-public emacs-golden-ratio
+  (let ((commit "375c9f287dfad68829582c1e0a67d0c18119dab9")
+        (revision "0"))
+    (package
+      (name "emacs-golden-ratio")
+      (version (git-version "1.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/roman/golden-ratio.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0a635a3h6jx0clgwmhwc48i14y3xy5q29y37lp2sjnbxx1hlmkli"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/roman/golden-ratio.el")
+      (synopsis "Automatic resizing of Emacs windows to the golden ratio")
+      (description "This package provides an Emacs mode for automatically
+resizing the window that has main focus to be more convenient for editing,
+while the ones that are not being actively edited will be reduced to a smaller
+size.")
+      (license license:expat))))
+
 (define-public emacs-git-modes
   (package
     (name "emacs-git-modes")