summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-11 00:04:46 +0000
committerLeo Famulari <leo@famulari.name>2021-10-12 11:05:21 -0400
commit385c9a4e30e952207df3246acaf13e6519b01af2 (patch)
tree33226275cfd4643c5d52aa95562ce986ab2b4419
parentfa2c1adb0247f2618d0720a41023f0f5339685c7 (diff)
downloadguix-385c9a4e30e952207df3246acaf13e6519b01af2.tar.gz
gnu: kdenlive: Update to 21.08.2.
* gnu/packages/kde.scm (kdenlive): Update to 21.08.2.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/kde.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 1d064fed2a..6cba017af0 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -219,7 +219,7 @@ browser for easy news reading.")
     (license license:gpl2+)))
 
 (define-public kdenlive
-  (let ((version "21.08.1"))
+  (let ((version "21.08.2"))
     (package
       (name "kdenlive")
       (version version)
@@ -231,7 +231,7 @@ browser for easy news reading.")
                (commit (string-append "v" version))))
          (file-name (string-append name "-" version "-checkout"))
          (sha256
-          (base32 "1fvy2aa86pn4crk8lgxjh1kdn2lxzi66krnrr9m91mp89mmc760k"))))
+          (base32 "1l78xjdf1bmj3s8kysaqqgh67mb3vrc96rsdnp0i4awlyfsh89d7"))))
       (build-system qt-build-system)
       (native-inputs
        `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -269,7 +269,10 @@ browser for easy news reading.")
          ("qtwebkit" ,qtwebkit)
          ("shared-mime-info" ,shared-mime-info)))
       (arguments
-       `(#:tests? #f                    ;TODO needs X
+       ;; XXX: there is a single test that spawns other tests and
+       ;; 1/3 tests failed and 1/327 assertions failed.  It seems
+       ;; that individual tests can't be skipped.
+       `(#:tests? #f
          #:phases
          (modify-phases %standard-phases
            (add-after 'install 'wrap-executable