summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:41 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:53 +0100
commit388f8f033e39c78c7f62ef46f991b56a6071c157 (patch)
tree63d4f552692f434c55d50754dfb72c42ba0dcd24
parent2428ab7527e91bba02743a19c1e8ce29b28e553d (diff)
downloadguix-388f8f033e39c78c7f62ef46f991b56a6071c157.tar.gz
gnu: ghc-vector: Update to 0.12.3.1.
* gnu/packages/haskell-xyz.scm (ghc-vector): Update to 0.12.3.1.
[inputs]: Remove ghc-random and ghc-quickcheck.
-rw-r--r--gnu/packages/haskell-xyz.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b83628e9d8..d034f92773 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -14683,7 +14683,7 @@ representing a store for a single element.")
 (define-public ghc-vector
   (package
     (name "ghc-vector")
-    (version "0.12.3.0")
+    (version "0.12.3.1")
     (outputs '("out" "static" "doc"))
     (source
      (origin
@@ -14694,7 +14694,7 @@ representing a store for a single element.")
              ".tar.gz"))
        (sha256
         (base32
-         "00xp86yad3yv4ja4q07gkmmcf7iwpcnzkkaf91zkx9nxb981iy0m"))))
+         "0dczbcisxhhix859dng5zhxkn3xvlnllsq60apqzvmyl5g056jpv"))))
     (build-system haskell-build-system)
     ;; FIXME: To simplify upgrading all Haskell packages, we leave the tests
     ;; disabled for now.
@@ -14702,8 +14702,6 @@ representing a store for a single element.")
      `(#:tests? #f))
     (inputs
      `(("ghc-primitive" ,ghc-primitive)
-       ("ghc-random" ,ghc-random)
-       ("ghc-quickcheck" ,ghc-quickcheck)
        ;; ("ghc-hunit" ,ghc-hunit)
        ;; ("ghc-test-framework" ,ghc-test-framework)
        ;; ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)