summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-27 23:40:30 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 13:59:00 +0100
commit39033c8f5719d85736798f3101022cca8ea92e5d (patch)
tree15a4f37624e67d1f71ccd8f39d44d90587e5b650
parent0ab4c3928502dd3621c9a4592295a48ad7cee4ee (diff)
downloadguix-39033c8f5719d85736798f3101022cca8ea92e5d.tar.gz
gnu: python2-bandit: Enable tests.
* gnu/packages/openstack.scm (python-bandit)[properties]: Remove.
(python2-bandit): Don't use STRIP-PYTHON2-VARIANT.
-rw-r--r--gnu/packages/openstack.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index bcd075424d..2767d6d58a 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -72,16 +72,10 @@
 To do this Bandit processes each file, builds an AST from it, and runs
 appropriate plugins against the AST nodes.  Once Bandit has finished scanning
 all the files it generates a report.")
-    (properties `((python2-variant . ,(delay python2-bandit))))
     (license asl2.0)))
 
 (define-public python2-bandit
-  (package (inherit (package-with-python2
-                     (strip-python2-variant python-bandit)))
-           (arguments
-            `(#:python ,python-2
-              ;; FIXME: 'subunit.run discover: error: no such option: --list'
-              #:tests? #f))))
+  (package-with-python2 python-bandit))
 
 (define-public python-debtcollector
   (package