summary refs log tree commit diff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2022-01-13 10:50:34 +0100
committerLeo Famulari <leo@famulari.name>2022-01-13 14:03:10 -0500
commit391f22fa3e34ac0ef0c31a422ccfb49c92f744ac (patch)
treeca7b48740a461f01637a4766f906953af8a65f87
parent66ab299a076b27854a5e4be5c0960ad306682e76 (diff)
downloadguix-391f22fa3e34ac0ef0c31a422ccfb49c92f744ac.tar.gz
gnu: poetry: Use an old msgpack implementation.
* gnu/packages/python-xyz.scm (poetry)[propagated-inputs]: Replace
python-msgpack with python-msgpack-transitional.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66ec26d142..0091165d37 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16119,7 +16119,9 @@ database, file, dict stores.  Cachy supports python versions 2.7+ and 3.2+.")
            python-entrypoints
            python-html5lib
            python-keyring
-           python-msgpack
+           ; Use of deprecated version of msgpack reported upstream:
+           ; https://github.com/python-poetry/poetry/issues/3607
+           python-msgpack-transitional
            python-packaging
            python-pexpect
            python-pip