summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 19:14:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-27 12:46:39 +0200
commit3a28209c316c8965b2669c6820fbd177ec572b76 (patch)
tree6886f2225a9e62bcbe3f85d5225ca0d2f8e7aea9
parent6023fa366db309202181e696f6aeee1d64ec331f (diff)
downloadguix-3a28209c316c8965b2669c6820fbd177ec572b76.tar.gz
gnu: discount: Return #t from all phases.
* gnu/packages/markup.scm (discount)[arguments]: Substitute INVOKE for
SYSTEM*.
-rw-r--r--gnu/packages/markup.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index bce411d0bd..e15e8497b7 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -137,10 +137,9 @@ convert it to structurally valid XHTML (or HTML).")
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (setenv "CC" "gcc")
-             (zero? (system*
-                     "./configure.sh"
+             (invoke "./configure.sh"
                      (string-append "--prefix=" (assoc-ref outputs "out"))
-                     "--shared")))))))
+                     "--shared"))))))
     (synopsis "Markdown processing library, written in C")
     (description
      "Discount is a markdown implementation, written in C.  It provides a