summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-28 09:53:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:58:58 +0200
commit3a28e1469684566d2d1fab36ccba5d963f4bdd45 (patch)
tree023f048ada6b7a683f423bd5bfb53a715033e290
parentc30fdd4ed85768f0a70bf4d081b9b2e8d3f6524f (diff)
downloadguix-3a28e1469684566d2d1fab36ccba5d963f4bdd45.tar.gz
gnu: Add rust-powerfmt-0.2.
* gnu/packages/crates-io.scm (rust-powerfmt-0.2): New variable.
(rust-powerfmt-macros-0.1): New variable.

Change-Id: I6d4771cfb2b2e8093cbb8d1bbe0a4b798d9fc633
-rw-r--r--gnu/packages/crates-io.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4f09ae8d35..b18104dbac 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -54660,6 +54660,51 @@ I/O library.")
 and Postgres values.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-powerfmt-0.2
+  (package
+    (name "rust-powerfmt")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "powerfmt" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "14ckj2xdpkhv3h6l5sdmb9f1d57z8hbfpdldjc2vl5givq2y77j3"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-powerfmt-macros" ,rust-powerfmt-macros-0.1))))
+    (home-page "https://github.com/jhpratt/powerfmt")
+    (synopsis "Library that provides utilities for formatting values")
+    (description
+     "`powerfmt` is a library that provides utilities for formatting values.
+This crate makes it significantly easier to support filling to a minimum width
+with alignment, avoid heap allocation, and avoid repetitive calculations.")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-powerfmt-macros-0.1
+  (package
+    (name "rust-powerfmt-macros")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "powerfmt-macros" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "097ir0g2hjq6sx20nc3k7r7cnyyflgn5lv64jmghyp5g63i5bwx8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-syn" ,rust-syn-2))))
+    (home-page "https://github.com/jhpratt/powerfmt")
+    (synopsis "Procedural macros for `powerfmt`")
+    (description
+     "Procedural macros for `powerfmt`.  This crate is an implementation detail
+and should not be relied upon directly.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-ppv-lite86-0.2
   (package
     (name "rust-ppv-lite86")