summary refs log tree commit diff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-01-17 22:48:36 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 22:59:14 +0000
commit3aa92cc71f24b8a35fc77aaafdf9870313a0504e (patch)
treec2f32533d1b4d84cfa2ce8188fab00d8a584b8ec
parent51f8d606658bd3813dc0a395c5fa5bb937f35559 (diff)
downloadguix-3aa92cc71f24b8a35fc77aaafdf9870313a0504e.tar.gz
gnu: Add go-github-com-coreos-go-systemd-unit.
* gnu/packages/golang.scm (go-github-com-coreos-go-systemd-unit): New
  variable.

Change-Id: I4103a0a8a3fe8f0efe4e21b053cecda9825efdc1
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 6b18d33ed1..625abaf25b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -298,6 +298,20 @@ logind API.")))
     (description "Go bindings to systemd for registering
 machines/containers.")))
 
+(define-public go-github-com-coreos-go-systemd-unit
+  (package
+    (inherit go-github-com-coreos-go-systemd-activation)
+    (name "go-github-com-coreos-go-systemd-unit")
+    (arguments
+     '(#:tests? #f ;Tests require D-Bus daemon running.
+       #:import-path "github.com/coreos/go-systemd/unit"
+       #:unpack-path "github.com/coreos/go-systemd"))
+    (native-inputs (list go-github-com-godbus-dbus))
+    (home-page "https://github.com/coreos/go-systemd")
+    (synopsis "Go bindings to systemd for working with unit files")
+    (description "Go bindings to systemd for (de)serialization and comparison
+of unit files.")))
+
 (define-public go-github-com-cyberdelia-go-metrics-graphite
   (package
     (name "go-github-com-cyberdelia-go-metrics-graphite")