summary refs log tree commit diff
diff options
context:
space:
mode:
authorTomás Ortín Fernández <tomasortin@mailbox.org>2020-11-26 08:56:20 +0000
committerEfraim Flashner <efraim@flashner.co.il>2020-11-29 21:18:02 +0200
commit3c50f0892446f6d5c615e0c5915afb12705c6eeb (patch)
tree90ea7db381108628e04d4d818964b689cce06a19
parentc601e2bf9adb05dc9dd9f3a565f693e968eb785c (diff)
downloadguix-3c50f0892446f6d5c615e0c5915afb12705c6eeb.tar.gz
gnu: Add cgoban.
* gnu/packages/games.scm (cgoban): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/games.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1b7faa97c9..f17345e4e1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -55,6 +55,7 @@
 ;;; Copyright © 2020 Trevor Hass <thass@okstate.edu>
 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2020 Lu hux <luhux@outlook.com>
+;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11956,6 +11957,33 @@ computer opponents or against real players online.")
 inside the Zenith Colony.")
     (license license:gpl3+)))
 
+(define-public cgoban
+  (package
+    (name "cgoban")
+    (version "1.9.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/cgoban1/cgoban1/"
+                           version "/cgoban-" version ".tar.gz"))
+       (sha256
+        (base32 "0qlvkiaglqq0izfph3l04mp4rqqqm9ks6rcsrmzrggw9x706z2iv"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libx11" ,libx11)
+       ("libxt" ,libxt)
+       ("xorgproto" ,xorgproto)))
+    (home-page "http://cgoban1.sourceforge.net/")
+    (synopsis "Go client for X11")
+    (description "Provides a large set of Go-related services for X11:
+@itemize
+@item Local games with precise implementation of the Chinese and Japanese rulesets
+@item Edition and visualization of SGF files-Connection to the NNGS or IGS Go servers
+@item Bridge to Go modem protocol, allowing to play against Go modem-capable AIs
+such as GnuGo.
+@end itemize")
+    (license license:gpl2+)))
+
 (define-public paperview
   (let ((commit "9f8538eb6734c76877b878b8f1e52587f2ae19e6")
         (revision "1"))