summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 18:39:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:27 +0200
commit3d3a745a9e56bc21b0649651d81cffbffa527158 (patch)
tree6159f4359364df8b71299810e32ca968363dfe32
parent693f9daea908423302a4ec93dc4090aa995bbf9b (diff)
downloadguix-3d3a745a9e56bc21b0649651d81cffbffa527158.tar.gz
gnu: Add texlive-context-simpleslides.
* gnu/packages/tex.scm (texlive-context-simpleslides): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f78c3f1228..01b68872f5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10488,6 +10488,33 @@ layout of the base text and the Ruby text can be controlled by parameters.")
 ConTeXt.")
     (license license:gpl3+)))
 
+(define-public texlive-context-simpleslides
+  (package
+    (name "texlive-context-simpleslides")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/context/third/simpleslides/"
+                   "scripts/context/lua/third/simpleslides/"
+                   "tex/context/interface/third/"
+                   "tex/context/third/simpleslides/")
+             (base32
+              "0vbh26ym42ayxwis6wbkmf07sy167g9kzg5ls889j2f2zn5rf4pr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-context))
+    (home-page "https://ctan.org/pkg/context-simpleslides")
+    (synopsis "Module for preparing presentations")
+    (description
+     "This ConTeXt module provides an easy-to-use interface for creating
+presentations for use with a digital projector.  The presentations are
+not interactive (no buttons, hyperlinks or navigational tools such as
+tables of contents).  Graphics may be mixed with the text of slides.
+The module provides several predefined styles, designed for academic
+presentation.  Most styles are configurable, and it is easy to design
+new styles.")
+    (license license:gpl3+)))
+
 (define-public texlive-beamer
   (package
     (name "texlive-beamer")