summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 10:59:56 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:29 +0100
commit3d74d84235038a8329a734918c3dd0093c4935ab (patch)
treeab7eecdd2d825efa75fe40f81a9b48255536b501
parent9ba9487306843c7c959e62ab28e6197801828580 (diff)
downloadguix-3d74d84235038a8329a734918c3dd0093c4935ab.tar.gz
gnu: Remove ocaml4.07-ppx-base.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-base): Remove variable.
(ocaml-ppx-base)[properties]: Remove variant.

Change-Id: I1a079a895eb260bb6870a12f494b79869a5a350c
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 1 insertions, 21 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 860ff4f752..ae549473f7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7632,8 +7632,7 @@ conversion functions between almost identical types.")
            ocaml-ppx-sexp-conv
            ocaml-migrate-parsetree
            ocaml-ppxlib))
-    (properties `((upstream-name . "ppx_base")
-                  (ocaml4.07-variant . ,(delay ocaml4.07-ppx-base))))
+    (properties `((upstream-name . "ppx_base")))
     (home-page "https://github.com/janestreet/ppx_base")
     (synopsis "Base set of ppx rewriters")
     (description "Ppx_base is the set of ppx rewriters used for Base.
@@ -7642,25 +7641,6 @@ Note that Base doesn't need ppx to build, it is only used as a
 verification tool.")
     (license license:asl2.0)))
 
-(define-public ocaml4.07-ppx-base
-  (package-with-ocaml4.07
-   (package
-     (inherit ocaml-ppx-base)
-     (version "0.11.0")
-     (source
-      (janestreet-origin
-       "ppx_base" version
-       "0aq206pg330jmj7lhcagiiwm3a0b3gsqm801m8ajd4ysyw7idkym"))
-    (propagated-inputs
-     `(("ocaml-ppx-compare" ,ocaml-ppx-compare)
-       ("ocaml-ppx-enumerate" ,ocaml-ppx-enumerate)
-       ("ocaml-ppx-hash" ,ocaml-ppx-hash)
-       ("ocaml-ppx-js-style" ,ocaml-ppx-js-style)
-       ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
-       ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
-       ("ocaml-ppxlib" ,ocaml-ppxlib)))
-    (properties `((upstream-name . "ppx_base"))))))
-
 (define-public ocaml-ppx-bin-prot
   (package
     (name "ocaml-ppx-bin-prot")