summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-10 14:53:39 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-11 15:48:05 -0500
commit3deac8c17b3ec6834437596cc3d9655724806651 (patch)
tree591796dac5c22cfb55a49d8dd259e7f276d38267
parent8142aff3f675df50495fcf1a89903a06bb930660 (diff)
downloadguix-3deac8c17b3ec6834437596cc3d9655724806651.tar.gz
gnu: Add Time-Local.
* gnu/packages/perl.scm (perl-time-local): New variable.
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 44332fe519..bd15f80aa1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2085,6 +2085,27 @@ used to match against text, rather than fetching names from a filesystem.  If
 you want to do full file globbing use the File::Glob module instead.")
     (license (package-license perl))))
 
+(define-public perl-time-local
+  (package
+    (name "perl-time-local")
+    (version "1.2300")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/"
+                           "Time-Local-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0jgvd6v93hlrcmy56yxbm4yrhzi8yvrq8c3xffpgh28af01wmb5j"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Time-Local")
+    (synopsis "Efficiently compute time from local and GMT time")
+    (description "This module provides functions that are the inverse of
+built-in perl functions localtime() and gmtime().  They accept a date as a
+six-element array, and return the corresponding time(2) value in seconds since
+the system epoch")
+    (license (package-license perl))))
+
 (define-public perl-try-tiny
   (package
     (name "perl-try-tiny")