summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-12-15 23:27:56 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-15 23:27:56 +0100
commit3e778ad3af53e343550f4ec3d0b56f9bfe1fa2e3 (patch)
treef2c83b46cfdbaec390bf7259ab69cd1a08a67e23
parent2ed5b0f42c40b5eb8df462b3cff3399123423182 (diff)
downloadguix-3e778ad3af53e343550f4ec3d0b56f9bfe1fa2e3.tar.gz
gnu: Move libelf and patchelf to (gnu packages elf).
* gnu/packages/patchelf.scm (patchelf): Move to...
* gnu/packages/elf.scm (patchelf): ... here.
* gnu/packages/patchelf.scm: Remove.
* gnu-system.am (GNU_SYSTEM_MODULES): Adjust accordingly.
* gnu/packages/gcc.scm (libelf): Move to...
* gnu/packages/elf.scm (libelf): ... here.
* gnu/packages/cdrom.scm, gnu/packages/icu4c.scm,
  gnu/packages/samba.scm, gnu/packages/scheme.scm, gnu/packages/ssh.scm:
  Adjust references to (gnu packages patchelf).
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/cdrom.scm2
-rw-r--r--gnu/packages/elf.scm51
-rw-r--r--gnu/packages/gcc.scm28
-rw-r--r--gnu/packages/icu4c.scm2
-rw-r--r--gnu/packages/patchelf.scm46
-rw-r--r--gnu/packages/python.scm2
-rw-r--r--gnu/packages/samba.scm2
-rw-r--r--gnu/packages/scheme.scm2
-rw-r--r--gnu/packages/ssh.scm2
10 files changed, 57 insertions, 81 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 51a455e55b..c5134740de 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -148,7 +148,6 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/package-management.scm		\
   gnu/packages/parallel.scm			\
   gnu/packages/parted.scm			\
-  gnu/packages/patchelf.scm			\
   gnu/packages/pcre.scm				\
   gnu/packages/pdf.scm				\
   gnu/packages/pem.scm				\
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index df5d077e7a..e54cce55fd 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -29,7 +29,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages help2man)
   #:use-module (gnu packages ncurses)
-  #:use-module (gnu packages patchelf)
+  #:use-module (gnu packages elf)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages which))
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 83ec8fbc5c..1df9956f87 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -20,7 +20,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module ((guix licenses) #:select (lgpl3+))
+  #:use-module ((guix licenses) #:select (gpl3+ lgpl3+ lgpl2.0+))
   #:use-module (gnu packages m4)
   #:use-module (gnu packages compression))
 
@@ -51,3 +51,52 @@
 
     ;; Libraries are dual-licensed LGPLv3.0+ | GPLv2, and programs are GPLv3+.
     (license lgpl3+)))
+
+(define-public libelf
+  (package
+    (name "libelf")
+    (version "0.8.13")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "http://www.mr511.de/software/libelf-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "0vf7s9dwk2xkmhb79aigqm0x0yfbw1j0b9ksm51207qwr179n6jr"))))
+    (build-system gnu-build-system)
+    (arguments '(#:phases (alist-replace
+                           'configure
+                           (lambda* (#:key outputs #:allow-other-keys)
+                             ;; This old `configure' script doesn't support
+                             ;; variables passed as arguments.
+                             (let ((out (assoc-ref outputs "out")))
+                               (setenv "CONFIG_SHELL" (which "bash"))
+                               (zero?
+                                (system* "./configure"
+                                         (string-append "--prefix=" out)))))
+                           %standard-phases)))
+    (home-page "http://www.mr511.de/software/english.html")
+    (synopsis "An ELF object file access library")
+    (description "libelf is a C library to access ELF object files.")
+    (license lgpl2.0+)))
+
+(define-public patchelf
+  (package
+    (name "patchelf")
+    (version "0.6")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "http://nixos.org/releases/patchelf/patchelf-"
+                   version
+                   "/patchelf-" version ".tar.bz2"))
+             (sha256
+              (base32
+               "00bw29vdsscsili65wcb5ay0gvg1w0ljd00sb5xc6br8bylpyzpw"))))
+    (build-system gnu-build-system)
+    (home-page "http://nixos.org/patchelf.html")
+    (synopsis "Modify the dynamic linker and RPATH of ELF executables")
+    (description
+     "PatchELF allows the ELF \"interpreter\" and RPATH of an ELF binary to be
+changed.")
+    (license gpl3+)))
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index bcaab30886..279cc8d950 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -24,6 +24,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages texinfo)
+  #:use-module (gnu packages elf)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
@@ -324,30 +325,3 @@ CLooG is designed to avoid control overhead and to produce a very
 effective code.")
     (license gpl2+)))
 
-(define-public libelf
-  (package
-    (name "libelf")
-    (version "0.8.13")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "http://www.mr511.de/software/libelf-"
-                                 version ".tar.gz"))
-             (sha256
-              (base32
-               "0vf7s9dwk2xkmhb79aigqm0x0yfbw1j0b9ksm51207qwr179n6jr"))))
-    (build-system gnu-build-system)
-    (arguments '(#:phases (alist-replace
-                           'configure
-                           (lambda* (#:key outputs #:allow-other-keys)
-                             ;; This old `configure' script doesn't support
-                             ;; variables passed as arguments.
-                             (let ((out (assoc-ref outputs "out")))
-                               (setenv "CONFIG_SHELL" (which "bash"))
-                               (zero?
-                                (system* "./configure"
-                                         (string-append "--prefix=" out)))))
-                           %standard-phases)))
-    (home-page "http://www.mr511.de/software/english.html")
-    (synopsis "An ELF object file access library")
-    (description "libelf is a C library to access ELF object files.")
-    (license lgpl2.0+)))
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index d5abb2c0f3..6129662436 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -18,7 +18,7 @@
 
 (define-module (gnu packages icu4c)
   #:use-module (gnu packages)
-  #:use-module (gnu packages patchelf)
+  #:use-module (gnu packages elf)
   #:use-module (gnu packages perl)
   #:use-module (guix licenses)
   #:use-module (guix packages)
diff --git a/gnu/packages/patchelf.scm b/gnu/packages/patchelf.scm
deleted file mode 100644
index 1bbe010ce1..0000000000
--- a/gnu/packages/patchelf.scm
+++ /dev/null
@@ -1,46 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages patchelf)
-  #:use-module (guix licenses)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
-
-(define-public patchelf
-  (package
-    (name "patchelf")
-    (version "0.6")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append
-                   "http://nixos.org/releases/patchelf/patchelf-"
-                   version
-                   "/patchelf-"
-                   version
-                   ".tar.bz2"))
-             (sha256
-              (base32
-               "00bw29vdsscsili65wcb5ay0gvg1w0ljd00sb5xc6br8bylpyzpw"))))
-    (build-system gnu-build-system)
-    (home-page "http://nixos.org/patchelf.html")
-    (synopsis "Modify the dynamic linker and RPATH of ELF executables")
-    (description
-     "PatchELF allows the ELF \"interpreter\" and RPATH of an ELF binary to be
-changed.")
-    (license gpl3+)))
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6d2c940773..faf2c9d527 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -29,7 +29,7 @@
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages openssl)
-  #:use-module (gnu packages patchelf)
+  #:use-module (gnu packages elf)
   #:use-module (gnu packages sqlite)
   #:use-module (guix packages)
   #:use-module (guix download)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index e0199bce90..5b52a38e4a 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -27,7 +27,7 @@
   #:use-module (gnu packages readline)
   #:use-module (gnu packages libunwind)
   #:use-module (gnu packages linux)
-  #:use-module (gnu packages patchelf)
+  #:use-module (gnu packages elf)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python))
 
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index b43c58af10..4dcd46305d 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -26,7 +26,7 @@
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages emacs)
   #:use-module (gnu packages texinfo)
-  #:use-module (gnu packages patchelf)
+  #:use-module (gnu packages elf)
   #:use-module (gnu packages which)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages avahi)
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 1d3ba7d828..76d51c44c6 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -23,7 +23,7 @@
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages groff)
   #:use-module (gnu packages openssl)
-  #:use-module (gnu packages patchelf)
+  #:use-module (gnu packages elf)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages autotools)