summary refs log tree commit diff
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-16 21:58:36 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-17 09:35:30 +0100
commit3e92f4f945e271ea3cf20ea756e9b6f223f75f60 (patch)
treef442a8de988b138eea922fbc7150a1a86585a2c8
parent07f4aef0783e2e74499432d4cd9adce9cd084487 (diff)
downloadguix-3e92f4f945e271ea3cf20ea756e9b6f223f75f60.tar.gz
gnu: Add chibi-scheme.
* gnu/packages/scheme.scm (chibi-scheme): New variable.
-rw-r--r--gnu/packages/scheme.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index a41647520d..4d759fa11a 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -474,3 +474,38 @@ loaded at run time.  Interpreted code and compiled code can be freely
 mixed.")
     ;; Dual license.
     (license (list lgpl2.1+ asl2.0))))
+
+(define-public chibi-scheme
+  (package
+    (name "chibi-scheme")
+    (version "0.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://abrek.synthcode.com/chibi-scheme-" version ".tgz"))
+       (sha256
+        (base32 "0h6k2gdb4xk2pzhdipffcg2w3kfr4zh1va556k1hvng2did6prds"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (alist-delete
+        'configure
+        (alist-cons-before
+         'build 'set-cc
+         (lambda _
+           (setenv "CC" "gcc"))
+         %standard-phases))
+       #:make-flags (let ((out (assoc-ref %outputs "out")))
+                      (list (string-append "PREFIX=" out)
+                            (string-append "LDFLAGS=-Wl,-rpath=" out "/lib")))
+       #:test-target "test"))
+    (home-page "https://code.google.com/p/chibi-scheme/")
+    (synopsis "Small embeddable Scheme implementation")
+    (description
+     "Chibi-Scheme is a very small library with no external dependencies
+intended for use as an extension and scripting language in C programs.  In
+addition to support for lightweight VM-based threads, each VM itself runs in
+an isolated heap allowing multiple VMs to run simultaneously in different OS
+threads.")
+    (license bsd-3)))