summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-06 14:36:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-06 18:13:09 +0300
commit3ea2eaa8f35059ae64004d224992ee53a135cc80 (patch)
treec5e0a722ae3fc653a35f75216726cc22a4ad09cb
parent87cd1f5c2aabbd9eacd9926a2dc085fe6e5e1aa0 (diff)
downloadguix-3ea2eaa8f35059ae64004d224992ee53a135cc80.tar.gz
gnu: python-efl: Update to 1.20.0.
* gnu/packages/enlightenment.scm (python-efl): Update to 1.20.0.
[source]: Add alternate source uri.
[arguments]: Enable tests.
-rw-r--r--gnu/packages/enlightenment.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index c76dd6eeb6..b42e631b98 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -286,14 +286,17 @@ embedded systems.")
 (define-public python-efl
   (package
     (name "python-efl")
-    (version "1.19.0")
+    (version "1.20.0")
     (source
       (origin
         (method url-fetch)
-        (uri (pypi-uri "python-efl" version))
+        (uri (list
+               (pypi-uri "python-efl" version)
+               (string-append "http://download.enlightenment.org/rel/bindings/"
+                              "python/python-efl-" version ".tar.gz")))
         (sha256
          (base32
-          "0l0f9bv1134qh5376p5asycncidrhp8hdb6qwd8ybr1a61q9zq67"))))
+          "1680pgpf501nhbc9arm0nfj6rpcw17aryh0pgmmmszxlgpifpdzy"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -312,11 +315,7 @@ embedded systems.")
           (lambda _
             ;; Some tests require write access to HOME.
             (setenv "HOME" "/tmp")
-            #t)))
-       ;; FIXME: Some tests require a running D-Bus server or a network
-       ;; connection and should be disabled. Other test failures looks
-       ;; legitimate. Disabled for now, needs work!
-       #:tests? #f))
+            #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python-cython" ,python-cython)))