summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2023-07-23 18:38:06 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-24 16:42:42 +0100
commit3f30f7d78c072e8a95ff737031fe6489f8103d1d (patch)
tree92dd8bb52bd91d5d5474c94f91abc2bb2f8cbf78
parenta2fafccaeb04e683ee2441052b3cb811f8fa3baf (diff)
downloadguix-3f30f7d78c072e8a95ff737031fe6489f8103d1d.tar.gz
gnu: Add ruby-time.
* gnu/packages/ruby.scm (ruby-time): New variable.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b82a972316..c30a47c732 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -738,6 +738,30 @@ includes the @code{Comparable} module for handling dates.")
     (home-page "https://github.com/ruby/date")
     (license license:bsd-2)))
 
+(define-public ruby-time
+  (package
+    (name "ruby-time")
+    (version "0.3.0")
+    (source (origin
+              (method git-fetch)  ; for tests
+              (uri (git-reference
+                    (url "https://github.com/ruby/time")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0jd6df2lxd60wcxyaf37j8v3nnfn952d5xhg6aap9zlcdmkk4g2n"))))
+    (build-system ruby-build-system)
+    (propagated-inputs (list ruby-date))
+    (native-inputs (list ruby-test-unit-ruby-core))
+    (synopsis
+     "Extends the Time class with methods for parsing and conversion")
+    (description
+     "When this gem is @code{require}d, it extends the Time class with with
+additional methods for parsing and converting Times.")
+    (home-page "https://github.com/ruby/time")
+    (license license:bsd-2)))
+
 (define-public ruby-diff-lcs
   (package
     (name "ruby-diff-lcs")