summary refs log tree commit diff
diff options
context:
space:
mode:
authorRovanion Luckey <rovanion.luckey@gmail.com>2023-10-21 23:05:01 +0200
committerLudovic Courtès <ludo@gnu.org>2023-11-15 18:29:37 +0100
commit3fe31e37a9c92a413530cb86a58921af6b407706 (patch)
tree2d45ff093a0abb1478de035a6807cdc9ca85ad0a
parent26a403f357f4471b14db7f01bb83a4c36ca5ef1b (diff)
downloadguix-3fe31e37a9c92a413530cb86a58921af6b407706.tar.gz
gnu: musescore: Update to 4.1.1.
* gnu/packages/music.scm (musescore): Update to 4.1.1.
[source]: Remove deletion of “thirdparty/freetype” from snippet.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Change-Id: If1c8e6ddd5bfa30c24ee0e8ef29c945242905d74
-rw-r--r--gnu/packages/music.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 85be6f6151..b5f7d882e4 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4982,7 +4982,7 @@ includes LV2 plugins and a JACK standalone client.")
 (define-public musescore
   (package
     (name "musescore")
-    (version "4.0.2")
+    (version "4.1.1")
     (source
      (origin
        (method git-fetch)
@@ -4991,14 +4991,11 @@ includes LV2 plugins and a JACK standalone client.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1yri94xs4xw0lsvmk5q7bqnpgmdadchfn08r7bb2y07jsi8qgm6w"))
+        (base32 "12h26k9qnsq027gdpch579nchwrqva1ymwm2fj5xmlh0aayrwy4d"))
        (modules '((guix build utils)))
        (snippet
         '(begin
-           ;; Remove unused libraries...
-           (for-each delete-file-recursively
-                     '("thirdparty/freetype"))
-           ;; ... and precompiled binaries.
+           ;; Delete precompiled binaries.
            (delete-file-recursively "src/diagnostics/crashpad_handler")
            (substitute* "src/diagnostics/CMakeLists.txt"
              (("install") "#install"))))))