summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-22 16:30:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-22 16:30:25 +0300
commit3fef44ed6c21e5bbc0da60d8a81d3973851ee3a2 (patch)
tree321a0fdce60bb470ca33cdb54e4884b509b9471f
parentfdd066833ee88da41fd5c4aa17b05f34e0618b00 (diff)
downloadguix-3fef44ed6c21e5bbc0da60d8a81d3973851ee3a2.tar.gz
Revert "gnu: texlive-latex-psnfss: Ensure that font definition files are installed."
This reverts commit fdd066833ee88da41fd5c4aa17b05f34e0618b00.

This commit causes over 4000 package rebuilds.
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 23 insertions, 19 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2609d5ae60..8ecdbf140c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3336,25 +3336,29 @@ language that is written in a Cyrillic alphabet.")
     (license license:lppl1.3c+)))
 
 (define-public texlive-latex-psnfss
-  (let ((template (simple-texlive-package
-                   "texlive-latex-psnfss"
-                   (list "/doc/latex/psnfss/"
-                         "/tex/latex/psnfss/")
-                   (base32
-                    "12p23in2nz1n08hw3m6kf5mcbn9zbhjsvdx0nsb7zcvywbljb9i2")
-                   #:trivial? #t)))
-    (package
-      (inherit template)
-      (home-page "https://www.ctan.org/pkg/psnfss")
-      (synopsis "Font support for common PostScript fonts")
-      (description "The PSNFSS collection includes a set of files that
-provide a complete working setup of the LaTeX font selection
-scheme (NFSS2) for use with common PostScript fonts.  It covers the
-so-called \"Base\" fonts (which are built into any Level 2 PostScript
-printing device and the Ghostscript interpreter) and a number of free
-fonts.  It provides font definition files, macros and font metrics.
-The bundle as a whole is part of the LaTeX required set of packages.")
-      (license license:lppl1.2+))))
+  (package
+    (name "texlive-latex-psnfss")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "psnfss"))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "1920dcq8613yzprasbg80fh4fcjcidvvl54wkx438nimyxcri7qz"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "latex/psnfss"))
+    (home-page "https://www.ctan.org/pkg/psnfss")
+    (synopsis "Font support for common PostScript fonts")
+    (description
+     "The PSNFSS collection includes a set of files that provide a complete
+working setup of the LaTeX font selection scheme (NFSS2) for use with common
+PostScript fonts.  It covers the so-called \"Base\" fonts (which are built
+into any Level 2 PostScript printing device and the Ghostscript interpreter)
+and a number of free fonts.  It provides font definition files, macros and
+font metrics.  The bundle as a whole is part of the LaTeX required set of
+packages.")
+    (license license:lppl1.2+)))
 
 ;; For user profiles
 (define-public texlive-base