summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-14 16:11:32 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:41 +0800
commit3ffcf8993959051dba992b2e512808785de1cd61 (patch)
treeb9a98087221c3a7b057de05d546e6a144e2327a4
parent4aed5b7abbd0f461751ced911a052fbc906fab76 (diff)
downloadguix-3ffcf8993959051dba992b2e512808785de1cd61.tar.gz
gnu: kdeconnect: Update to 23.04.3.
* gnu/packages/kde.scm (kdeconnect): Update to 23.04.3.
[native-inputs]: Add wayland-protocols.
[inputs]: Add modemmanager-qt, libxkbcommon.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/kde.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index b1b357bf64..1ef2a6b17f 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -924,16 +924,16 @@ different notification systems.")
 (define-public kdeconnect
   (package
     (name "kdeconnect")
-    (version "22.08.1")
+    (version "23.04.3")
     (source
-      (origin
-        (method url-fetch)
-        (uri (string-append "mirror://kde/stable/release-service/"
-                            version "/src/kdeconnect-kde-"
-                            version ".tar.xz"))
-        (sha256
-         (base32
-          "1yzx49gcm7x2wdk53iznyjz09y2a6mrrhh68xilbcsafyiw3l3zr"))))
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/"
+                           version "/src/kdeconnect-kde-"
+                           version ".tar.xz"))
+       (sha256
+        (base32
+         "1gcmqqj752h3lmcpvc7cm6k6bpb158ha7i5ysp0kqvf8cmpi5ydz"))))
     (build-system qt-build-system)
     (arguments
      `(#:configure-flags '("-DBUILD_TESTING=ON"
@@ -946,7 +946,8 @@ different notification systems.")
            kdoctools
            libxtst
            pkg-config
-           python-wrapper))
+           python-wrapper
+           wayland-protocols))
     (inputs
      (list kcmutils
            kconfigwidgets
@@ -974,7 +975,9 @@ different notification systems.")
            qtquickcontrols2-5
            qtx11extras
            qtwayland-5
-           wayland))
+           wayland
+           modemmanager-qt
+           libxkbcommon))
     (home-page "https://community.kde.org/KDEConnect")
     (synopsis "Enable your devices to communicate with each other")
     (description "KDE Connect is a project that enables all your devices to