summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2023-04-11 10:17:57 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2023-04-12 12:23:51 +0200
commit42b5c198d3659b155821e7454258727809ffb170 (patch)
treedc92213414306d4797e00c5d77bb569977d231e5
parentdf85f18ded1e02de7257f7c622f7ebd36a74806e (diff)
downloadguix-42b5c198d3659b155821e7454258727809ffb170.tar.gz
gnu: Add cl-steamworks.
* gnu/packages/lisp-xyz.scm (cl-steamworks, ecl-cl-steamworks,
sbcl-cl-steamworks): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d605cfaf5b..46eceb736d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -28840,6 +28840,43 @@ and so on easy.")
 (define-public ecl-cl-modio
   (sbcl-package->ecl-package sbcl-cl-modio))
 
+(define-public sbcl-cl-steamworks
+  (let ((commit "9d6a4de653a8cc256ae35e0298912b518aa92ba3")
+        (revision "1"))
+    (package
+      (name "sbcl-cl-steamworks")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shinmera/cl-steamworks/")
+               (commit commit)))
+         (sha256
+          (base32 "1fzj3rlqw1kwdlmh0ga0y71p2n1adflcamzx4yp9kga552c1db5j"))
+         (file-name (git-file-name "cl-steamworks" version))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       (list sbcl-alexandria
+             sbcl-babel
+             sbcl-cffi
+             sbcl-documentation-utils
+             sbcl-float-features
+             sbcl-trivial-features
+             sbcl-trivial-garbage
+             sbcl-trivial-gray-streams))
+      (synopsis "Wrapper for the Valve SteamWorks API")
+      (description "This is a wrapper library to allow you to interface with
+the Valve SteamWorks API.")
+      (home-page "https://shinmera.github.io/cl-steamworks/")
+      (license license:zlib))))
+
+(define-public cl-steamworks
+  (sbcl-package->cl-source-package sbcl-cl-steamworks))
+
+(define-public ecl-cl-steamworks
+  (sbcl-package->ecl-package sbcl-cl-steamworks))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar