summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 07:43:44 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:25 +0100
commit42e712867332ab421b3d38e67ca4b5dbba3e8061 (patch)
treecd859a21db3eb2bb2d65ac2bb8be073a0ba92ad4
parent25a221a80b29900538438926123ba253a6b0341c (diff)
downloadguix-42e712867332ab421b3d38e67ca4b5dbba3e8061.tar.gz
gnu: Add ghc-language-javascript.
* gnu/packages/haskell-web.scm (ghc-language-javascript): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/haskell-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 39ffe0f8d5..314e5b1e1b 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1808,3 +1808,35 @@ declarative and monadic interface.")
 proposed by Google and Mozilla here
 @url{https://wiki.mozilla.org/DevTools/Features/SourceMap}.")
     (license license:bsd-3)))
+
+(define-public ghc-language-javascript
+  (package
+    (name "ghc-language-javascript")
+    (version "0.7.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://hackage/package/language-javascript/language-javascript-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "15bpqpkjf2y3fk8wff9zlnkpsjc63bnbvhlkxrs9alj0bikq17nk"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-blaze-builder" ,ghc-blaze-builder)
+       ("ghc-utf8-string" ,ghc-utf8-string)))
+    (native-inputs
+     `(("ghc-alex" ,ghc-alex)
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-happy" ,ghc-happy)
+       ("ghc-hspec" ,ghc-hspec)
+       ("ghc-utf8-light" ,ghc-utf8-light)))
+    (home-page
+     "https://github.com/erikd/language-javascript")
+    (synopsis "Parser for JavaScript")
+    (description
+     "Parses Javascript into an Abstract Syntax Tree (AST).  Initially intended
+as frontend to hjsmin.")
+    (license license:bsd-3)))