summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:28:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:20 +0200
commit43d15fca608594a715b682b4a18c2f253a80b765 (patch)
treec4511a16c97a7708927188d475c3635d204537e9
parent72640f773a7160b445df8cc5214aaaa7b11c311a (diff)
downloadguix-43d15fca608594a715b682b4a18c2f253a80b765.tar.gz
gnu: Add texlive-texonly.
* gnu/packages/tex.scm (texlive-texonly): New variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a0c8d3630..d3e47543d5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25547,6 +25547,24 @@ TeX (the engine) works in as much detail as most ordinary TeX programmers will
 ever need to know.")
     (license license:fdl1.3+)))
 
+(define-public texlive-texonly
+  (package
+    (name "texlive-texonly")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/texonly/")
+             (base32
+              "0h40f8hj03ha0ilpj2fx5kzzvdv0yplmr4528s2rmmy62l9kgdkd")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/texonly")
+    (synopsis "Sample document in Plain TeX")
+    (description
+     "This package provides a file written with TeX, not using any packages,
+to be compiled with TeX or pdfTeX only, not with LaTeX and al.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-threeparttable
   (package
     (name "texlive-threeparttable")