summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-17 19:20:28 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-17 19:20:28 +0100
commit453118150957e3e2919a07d82e9908bdd99d25f4 (patch)
tree86f3a0849c86798577202c2420db4c3915bbf2fa
parent406d3a8efe059dc4f4b8a8d8171f766e0564daaf (diff)
downloadguix-453118150957e3e2919a07d82e9908bdd99d25f4.tar.gz
gnu: emacs-helm-lsp: Update to 0.2.
* gnu/packages/emacs-xyz.scm (emacs-helm-lsp): Update to 0.2.
-rw-r--r--gnu/packages/emacs-xyz.scm46
1 files changed, 22 insertions, 24 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f572b819e5..b22a3226f7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21919,31 +21919,29 @@ workspaces with a LSP-compliant server running.")
     (license license:gpl3+)))
 
 (define-public emacs-helm-lsp
-  (let ((commit "3a58ca4cfd94b9ab1e15e819d3b16ef568e8889b")
-        (revision "1"))
-    (package
-      (name "emacs-helm-lsp")
-      (version (git-version "0.1" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/emacs-lsp/helm-lsp")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0wh5zai3s17ss2q8wcdd6d87hv1h3nbyrxxs4js9cas8m6y2ssjv"))))
-      (build-system emacs-build-system)
-      (propagated-inputs
-       `(("emacs-helm" ,emacs-helm)
-         ("emacs-lsp-mode" ,emacs-lsp-mode)
-         ("emacs-dash" ,emacs-dash)))
-      (home-page "https://github.com/emacs-lsp/helm-lsp")
-      (synopsis "Provide LSP-enhanced completion for symbols")
-      (description
-       "This package enhances @code{helm} with completion for symbols from
+  (package
+    (name "emacs-helm-lsp")
+    (version "0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emacs-lsp/helm-lsp")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vq3qpqm3ndqyvf5bk8qhqcr60x9ykc0ipk2a43rr3yjm4z1b6s9"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-helm" ,emacs-helm)
+       ("emacs-lsp-mode" ,emacs-lsp-mode)
+       ("emacs-dash" ,emacs-dash)))
+    (home-page "https://github.com/emacs-lsp/helm-lsp")
+    (synopsis "Provide LSP-enhanced completion for symbols")
+    (description
+     "This package enhances @code{helm} with completion for symbols from
 workspaces with a LSP-compliant server running.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-helm-notmuch
   (package