summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-07-28 23:38:29 +0200
committerLeo Famulari <leo@famulari.name>2016-08-08 22:36:38 -0400
commit4532c0c0ab88c8f63fb853e2b8fe6ae55a29e89e (patch)
tree0e7e2d2360caf526b5fa9c15b6fac0d995c37609
parente741c4e42434d19d8d0bd37fec371042598efbd9 (diff)
downloadguix-4532c0c0ab88c8f63fb853e2b8fe6ae55a29e89e.tar.gz
gnu: Add perl-crypt-openssl-rsa.
* gnu/packages/tls.scm (perl-crypt-openssl-rsa): Add variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/tls.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 92564ba24d..a4a3038136 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -530,3 +530,31 @@ finally access to the SSL api of the SSLeay/OpenSSL package so you can write
 servers or clients for more complicated applications.")
     (license (package-license perl))
     (home-page "http://search.cpan.org/~mikem/Net-SSLeay-1.66/")))
+
+(define-public perl-crypt-openssl-rsa
+ (package
+  (name "perl-crypt-openssl-rsa")
+  (version "0.28")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (string-append
+             "mirror://cpan/authors/id/P/PE/PERLER/Crypt-OpenSSL-RSA-"
+             version
+             ".tar.gz"))
+      (sha256
+        (base32
+          "1gnpvv09b2gpifwdzc5jnhama3d1a4c39lzj9hcaicsb8rvzjmsk"))))
+  (build-system perl-build-system)
+  (inputs
+    `(("perl-crypt-openssl-bignum" ,perl-crypt-openssl-bignum)
+      ("perl-crypt-openssl-random" ,perl-crypt-openssl-random)
+      ("openssl" ,openssl)))
+  (arguments perl-crypt-arguments)
+  (home-page
+    "http://search.cpan.org/dist/Crypt-OpenSSL-RSA")
+  (synopsis
+    "RSA encoding and decoding, using the openSSL libraries")
+  (description "Crypt::OpenSSL::RSA does RSA encoding and decoding (using the
+OpenSSL libraries).")
+  (license (package-license perl))))