summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-20 20:19:54 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-22 15:52:49 +0300
commit4536c5a0a368bd0ecd2cb918b62cf6839b95e741 (patch)
tree8f58744d4b53ddefd49692524e5635c0ab9e5731
parentb7e76699d28b1fab55ec97c21e2c66f7c5b4dc8a (diff)
downloadguix-4536c5a0a368bd0ecd2cb918b62cf6839b95e741.tar.gz
gnu: emacs-epkg: Update to 3.2.2.
* gnu/packages/emacs-xyz.scm (emacs-epkg): Update to 3.2.2.
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 77b92d6046..5900b6b240 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13758,28 +13758,26 @@ add any additional instance slots.")
       (license license:gpl3))))
 
 (define-public emacs-epkg
-  ;; The release version is to old for the current database scheme.
-  (let ((commit "432312b9583ed7b88ad9644fd1bf2183765a892e"))
-    (package
-      (name "emacs-epkg")
-      (version (git-version "3.0.0" "1" commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/emacscollective/epkg")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0d882kahn7a0vri7a9r15lvmfx1zn2hsga6jfcc6jv0hqbswlb2k"))))
-      (build-system emacs-build-system)
-      (propagated-inputs
-       `(("emacs-closql" ,emacs-closql)
-         ("emacs-dash" ,emacs-dash)))
-      (home-page "https://emacsmirror.net")
-      (synopsis "Browse the Emacsmirror package database")
-      (description "This package provides access to a local copy of the
+  (package
+    (name "emacs-epkg")
+    (version "3.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emacscollective/epkg")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1pxz611qb3m33r6343h0xhwqvvhjl131zyc2klplzgb23rkm8lk0"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-closql" ,emacs-closql)
+       ("emacs-dash" ,emacs-dash)))
+    (home-page "https://emacsmirror.net")
+    (synopsis "Browse the Emacsmirror package database")
+    (description "This package provides access to a local copy of the
 Emacsmirror package database.  It provides low-level functions for querying
 the database and a @file{package.el} user interface for browsing the database.
 Epkg itself is not a package manager.
@@ -13799,7 +13797,7 @@ name and password.  To skip it press a @key{Return} key.
 
 You could get a Epkg package list by invoking @code{epkg-list-packages} in
 Emacs.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-elisp-slime-nav
   (package