summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-11 21:19:00 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-03 16:17:37 -0500
commit45ac52239a6f5c19e0ab324cff6c567a7e4e24d6 (patch)
treeb878f68be9dca40f08478837562e987aa04e4f56
parent2707b6ccd7c4bcccffebf6b782d0222974d11719 (diff)
downloadguix-45ac52239a6f5c19e0ab324cff6c567a7e4e24d6.tar.gz
gnu: %guile-static-stripped: Update to Guile 3.0.8.
* gnu/packages/make-bootstrap.scm (%guile-static-stripped): Use
guile-3.0-latest, currently at 3.0.8.  This resolves a segfault in the Guix
System Linux initrd when running Guile 3.0.7 on a Cortex A9 CPU (NXP i.MX6
Quad).
-rw-r--r--gnu/packages/make-bootstrap.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 4ea97368a9..24855f6b28 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -797,7 +797,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
   ;; A stripped static Guile 3.0 binary, for use in initrds
   ;; and during bootstrap.
   (make-guile-static-stripped
-   (make-guile-static guile-3.0
+   (make-guile-static guile-3.0-latest
                       '("guile-2.2-default-utf8.patch"
                         "guile-3.0-linux-syscalls.patch"
                         "guile-3.0-relocatable.patch"))))