summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 16:37:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:48 +0100
commit45b2eff0aa32315141c84dec915feb0e4dd71ac9 (patch)
tree46813b6e12816be1da5b772b6aecfa57d96148ca
parentd61236dffd7e6d58aebe08570d6a67b4bb5536d8 (diff)
downloadguix-45b2eff0aa32315141c84dec915feb0e4dd71ac9.tar.gz
gnu: l-smash: Fetch sources from git.
* gnu/packages/video.scm (l-smash)[source]: Fetch from git.
-rw-r--r--gnu/packages/video.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b36eafc711..936b912d2f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3064,14 +3064,14 @@ save it to the appropriate filename.")
     (name "l-smash")
     (version "2.14.5")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/" name "/" name "/archive/v"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/l-smash/l-smash.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0dary0h65kq6sv93iabv25djlvzr5ckdcp3ywagbix44wqfw7xz6"))))
+                "0rcq9727im6kd8da8b7kzzbzxdldvmh5nsljj9pvr4m3lj484b02"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ;no tests