summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-23 00:32:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-25 00:22:53 +0100
commit45f2d7eb900c175c3ea1a9123f43497c9b289506 (patch)
tree3a71cbcbe60b42ae22ec34971de657270c0a5630
parentdfcd913578b06723640ba0ad8567613a1fb799d2 (diff)
downloadguix-45f2d7eb900c175c3ea1a9123f43497c9b289506.tar.gz
gnu: Add emacs-malyon.
* gnu/packages/emacs-xyz.scm (emacs-malyon): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 41a0ccf09e..ee115192f9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Alex Kost <alezost@gmail.com>
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018, 2019 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2015, 2016, 2018, 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Adriano Peluso <catonano@gmail.com>
@@ -1319,6 +1319,28 @@ process, passing on the arguments as command line arguments.")
      "Magit-annex adds a few git-annex operations to the Magit interface.")
     (license license:gpl3+)))
 
+(define-public emacs-malyon
+  (package
+    (name "emacs-malyon")
+    (version "20161204")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/speedenator/malyon/")
+                    (commit "0d9882650720b4a791556f5e2d917388965d6fc0")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0an1yvp0p624rxd8n5phiwvznw35ripqhlwzwyv2bw7lc1rscllr"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/speedenator/malyon")
+    (synopsis "Z-machine interpreter")
+    (description
+     "Malyon is a Z-machine interpreter for playing text-based adventure
+games.  Malyon plays version 3 (.z3), version 5 (.z5), and version 8 (.z8) z
+code files.")
+    (license license:expat)))
+
 (define-public emacs-mct
   (package
     (name "emacs-mct")