summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-17 18:48:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:47 +0300
commit46492f6ec17b5abb9338633d147724215e8d3d94 (patch)
treeaa46f3a5f0d5e373e3ee52c0a8b5187d071507f5
parentaf40db2cc75d3355ceaa1438c478f595138b2f05 (diff)
downloadguix-46492f6ec17b5abb9338633d147724215e8d3d94.tar.gz
gnu: Remove rust-polars-core-0.16.
* gnu/packages/crates-io.scm (rust-polars-core-0.16): Delete variable.
-rw-r--r--gnu/packages/crates-io.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 660ba1d020..61e2a2a938 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45385,44 +45385,6 @@ applications.")
      "This crate provides the core of the Polars DataFrame library.")
     (license license:expat)))
 
-(define-public rust-polars-core-0.16
-  (package
-    (inherit rust-polars-core-0.17)
-    (name "rust-polars-core")
-    (version "0.16.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "polars-core" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0knhxc2b0k5jpvm7fxm64b5hjdyqgxjjyi6cnsiy5sya3mj3v9cd"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-ahash" ,rust-ahash-0.7)
-        ("rust-anyhow" ,rust-anyhow-1)
-        ("rust-arrow2" ,rust-arrow2-0.5)
-        ("rust-chrono" ,rust-chrono-0.4)
-        ("rust-comfy-table" ,rust-comfy-table-1)
-        ("rust-hashbrown" ,rust-hashbrown-0.11)
-        ("rust-itertools" ,rust-itertools-0.10)
-        ("rust-jsonpath-lib" ,rust-jsonpath-lib-0.3)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-ndarray" ,rust-ndarray-0.15)
-        ("rust-num" ,rust-num-0.4)
-        ("rust-num-cpus" ,rust-num-cpus-1)
-        ("rust-polars-arrow" ,rust-polars-arrow-0.16)
-        ("rust-prettytable-rs" ,rust-prettytable-rs-0.8)
-        ("rust-rand" ,rust-rand-0.7)
-        ("rust-rand-distr" ,rust-rand-distr-0.3)
-        ("rust-rayon" ,rust-rayon-1)
-        ("rust-regex" ,rust-regex-1)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-json" ,rust-serde-json-1)
-        ("rust-thiserror" ,rust-thiserror-1)
-        ("rust-unsafe-unwrap" ,rust-unsafe-unwrap-0.1))))))
-
 (define-public rust-polars-io-0.17
   (package
     (name "rust-polars-io")