summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2024-01-26 15:31:56 +0000
committerArun Isaac <arunisaac@systemreboot.net>2024-01-26 15:31:56 +0000
commit467192552859f8637a83304c1b101ed440de24e3 (patch)
treee86a4d7b5618635343b9b9c3f830c357c1bbebf7
parentcdf1d7dded027019f0ebbd5d6f0147b13dfdd28d (diff)
downloadguix-467192552859f8637a83304c1b101ed440de24e3.tar.gz
gnu: ccwl: Update to 0.3.0.
* gnu/packages/bioinformatics.scm (ccwl): Update to 0.3.0.
[arguments]: Add patch-more-source-shebangs phase.

Change-Id: Ic7926d04c28eeafd799deba5e817574663431db8
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7b2d910614..4db6987763 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -21742,7 +21742,7 @@ single-cell data named @url{https://github.com/PMBio/cardelino, cardelino}.")
 (define-public ccwl
   (package
     (name "ccwl")
-    (version "0.2.0")
+    (version "0.3.0")
     (source
      (origin
        (method url-fetch)
@@ -21750,7 +21750,7 @@ single-cell data named @url{https://github.com/PMBio/cardelino, cardelino}.")
                            version ".tar.lz"))
        (sha256
         (base32
-         "1ar8rfz3zrksgygrv67zv77y8gfvvz54zcs546jn6j28y20basla"))))
+         "0za710mcn9di1njli3dk3660n3836ip8b4msb8f958498va95y7j"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags '("GUILE_AUTO_COMPILE=0") ; to prevent guild warnings
@@ -21761,6 +21761,12 @@ single-cell data named @url{https://github.com/PMBio/cardelino, cardelino}.")
                            ,@%gnu-build-system-modules)
        #:phases
        (modify-phases %standard-phases
+         (add-after 'patch-source-shebangs 'patch-more-source-shebangs
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "scripts/ccwl"
+               (("^exec guile")
+                (string-append "exec "
+                               (search-input-file inputs "/bin/guile"))))))
          (add-after 'install 'wrap
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))