summary refs log tree commit diff
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-01 04:53:38 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-04 15:30:34 +0200
commit46b4f9b9a7e7fdd15bdc4562acaa816d3bf9d237 (patch)
tree835a8a50f5b0d78dc6e58fd1da6d29e1d972564e
parent88d5081986bb1f78b37a11e9e24f5658f2315558 (diff)
downloadguix-46b4f9b9a7e7fdd15bdc4562acaa816d3bf9d237.tar.gz
gnu: Add vim-nerdcommenter.
* gnu/packages/vim.scm (vim-nerdcommenter): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/vim.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index f70729952d..1abfffbce2 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1296,3 +1296,32 @@ a sidebar that displays the ctags-generated tags of the current file, ordered
 by their scope.  This means that for example methods in C++ are displayed under
 the class they are defined in.")
     (license license:vim)))
+
+(define-public vim-nerdcommenter
+  (let ((commit "a65465d321f2f8a74b2ffa540b9b87563f7e12e8")
+        (revision "1"))
+    (package
+      (name "vim-nerdcommenter")
+      (version (git-version "2.5.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+                (url "https://github.com/preservim/nerdcommenter")
+                (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "00ir65iv8jfbgzjmj7332fmydh0qhabbhx8zbvd3j6pgfxqpaafw"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan
+         '(("autoload" "share/vim/vimfiles/")
+           ("doc" "share/vim/vimfiles/")
+           ("plugin" "share/vim/vimfiles/"))))
+      (home-page "https://github.com/preservim/nerdcommenter")
+      (synopsis "Vim plugin for easy commenting of code")
+      (description
+       "NERD commenter is a Vim plugin that provides many different commenting
+operations and styles which are invoked via key mappings and a menu.  These
+operations are available for most filetypes.")
+      (license license:cc0))))