summary refs log tree commit diff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-04-14 16:44:43 +0000
committerLudovic Courtès <ludo@gnu.org>2022-04-20 23:46:44 +0200
commit4773664eb80feb5b9d8bd1f18adca8acaf6f9237 (patch)
tree7f7e85d687579d740827f0c83678d7ec702ed1c5
parentd2cb3f99057a53e32d97bde423de4eb81bf9df5b (diff)
downloadguix-4773664eb80feb5b9d8bd1f18adca8acaf6f9237.tar.gz
gnu: aws-c-s3: Update to 0.1.38.
* gnu/packages/c.scm (aws-c-s3): Update to 0.1.38.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/c.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 2e188af3f3..832b1c6e72 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -870,7 +870,7 @@ authentication.")
   (package
     (name "aws-c-s3")
     ; Update only when updating aws-crt-cpp.
-    (version "0.1.26")
+    (version "0.1.38")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -879,7 +879,7 @@ authentication.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0gaxnwwk0jbvkgjnxcgchq13xmn7jk5vjvjsps6b0vaz6bf12wv8"))))
+                "0n2y8hzb1bx3vnzlpb5hsav18dg33pwav0mpji6krz98y2l8msya"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags
@@ -888,7 +888,7 @@ authentication.")
                             (assoc-ref %build-inputs "aws-c-common"))
              "-DENABLE_NET_TESTS=OFF")))
     (propagated-inputs
-     (list aws-c-auth aws-c-http))
+     (list aws-c-auth aws-c-http aws-checksums))
     (synopsis "Amazon Web Services client library for Amazon S3")
     (description
      "This library provides a C99 client implementation of the Simple Storage