summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:29 +0200
commit47beef4b240b61c15b7a529c1f6ffd10241473f1 (patch)
tree226128f7e6df888c6690dccbe2728f43bc699a8f
parentfea0fb94d25b35b7b07b5e8dd69f461fd569eab4 (diff)
downloadguix-47beef4b240b61c15b7a529c1f6ffd10241473f1.tar.gz
gnu: Add texlive-quoting.
* gnu/packages/tex.scm (texlive-quoting): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fdf6bc90df..3fe8a16814 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93465,6 +93465,29 @@ Uses graphical and coloured output and by default needs the Adobe standard
 font set (as supported by @code{psnfss}).")
     (license license:gpl2)))
 
+(define-public texlive-quoting
+  (package
+    (name "texlive-quoting")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/quoting/" "source/latex/quoting/"
+                   "tex/latex/quoting/")
+             (base32
+              "035jilwq326893l3iza8dasznjfxvxg0w3r5zkygrjc5zycqmfp4")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/quoting")
+    (synopsis "Consolidated environment for displayed text")
+    (description
+     "As an alternative to the LaTeX standard environments @code{quotation} and
+@code{quote}, the package provides a consolidated environment for displayed
+text.  First-line indentation may be activated by adding a blank line before
+the quoting environment.  A key-value interface (using kvoptions) allows the
+user to configure font properties and spacing and to control orphans within
+and after the environment.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar