summary refs log tree commit diff
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2023-10-13 16:14:43 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-10-17 14:25:36 +0200
commit48f9484483a6f5c4a12ac3dc8e8cd1e26df58f9b (patch)
tree3fef97694ab339e7911c2da48200ef5c52f3bd46
parent54274a5a3bb5e2f637758d1d8797213d1ebaec20 (diff)
downloadguix-48f9484483a6f5c4a12ac3dc8e8cd1e26df58f9b.tar.gz
gnu: Add r-metacell.
* gnu/packages/bioinformatics.scm (r-metacell): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cb0bdf766e..45afde699d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10285,6 +10285,66 @@ figures.  This tool will create clean markdown reports about what you just
 discovered.")
       (license license:gpl3))))
 
+(define-public r-metacell
+  (let ((commit "d6a6926d103ee0cb34a611c753572429c94a53d9")
+        (revision "1"))
+    (package
+      (name "r-metacell")
+      (version (git-version "0.3.41" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/tanaylab/metacell/")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0zrsckr3y35x37mj3ibm6scyqx925s84wzrz1i42fnm9n3msc265"))))
+      (properties `((upstream-name . "metacell")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-cluster
+                               r-cowplot
+                               r-data-table
+                               r-dbscan
+                               r-domc
+                               r-dplyr
+                               r-entropy
+                               r-ggplot2
+                               r-graph
+                               r-igraph
+                               r-kernsmooth
+                               r-magrittr
+                               r-matrix
+                               r-matrixstats
+                               r-pdist
+                               r-pheatmap
+                               r-plyr
+                               r-rcolorbrewer
+                               r-rcurl
+                               r-rgraphviz
+                               r-slam
+                               r-singlecellexperiment
+                               r-svglite
+                               r-tgconfig
+                               r-tgstat
+                               r-tgutil
+                               r-tidyr
+                               r-umap
+                               r-umap
+                               r-zoo))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/tanaylab/metacell/")
+      (synopsis "Meta cell analysis for single cell RNA-seq data")
+      (description
+       "This package facilitates the analysis of single-cell RNA-seq UMI matrices.
+It does this by computing partitions of a cell similarity graph into
+small homogeneous groups of cells, which are defined as metacells (MCs).
+The derived MCs are then used for building different representations of
+the data, allowing matrix or 2D graph visualization forming a basis for
+analysis of cell types, subtypes, transcriptional gradients,cell-cycle
+variation, gene modules and their regulatory models and more.")
+      (license license:expat))))
+
 (define-public r-snapatac
   (package
     (name "r-snapatac")