summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 23:12:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:55 +0100
commit49e9a9aea2131f39c44689aebf02a87887cc0f87 (patch)
tree933b3a0d0c9cfe8fcd36062ae2d75dd01c7a55a8
parentd015db6f57888c5573dfb276121971cb7d44f4b7 (diff)
downloadguix-49e9a9aea2131f39c44689aebf02a87887cc0f87.tar.gz
gnu: Add r-acs.
* gnu/packages/cran.scm (r-acs): New variable.
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6c0bc01df0..76bae8ec93 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17664,3 +17664,36 @@ distribution.")
 regression coefficient vector in regression models with autocorrelated
 errors.")
     (license license:gpl2)))
+
+(define-public r-acs
+  (package
+    (name "r-acs")
+    (version "2.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "acs" version))
+       (sha256
+        (base32
+         "0ajw9rf8l8akcvgqvbxjvryc6wjx74521xyxswz2b0bky3m6kah5"))))
+    (properties `((upstream-name . "acs")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-httr" ,r-httr)
+       ("r-plyr" ,r-plyr)
+       ("r-rcpp" ,r-rcpp)
+       ("r-stringr" ,r-stringr)
+       ("r-xml" ,r-xml)))
+    (home-page "http://dusp.mit.edu/faculty/ezra-glenn")
+    (synopsis "Work with data from the US Census")
+    (description
+     "This package provides a general toolkit for downloading, managing,
+analyzing, and presenting data from the
+@url{https://www.census.gov/data/developers/data-sets.html, U.S.  Census},
+including SF1 (Decennial short-form), SF3 (Decennial long-form), and the
+American Community Survey (ACS).  Confidence intervals provided with ACS data
+are converted to standard errors to be bundled with estimates in complex
+@code{acs} objects.  The package provides new methods to conduct standard
+operations on @code{acs} objects and present/plot data in statistically
+appropriate ways.")
+    (license license:gpl3)))