summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-23 19:09:27 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-23 19:09:27 +0200
commit4a8b4c25b07eedd1427d8c33c01d0c7d6a0f17b5 (patch)
tree736bcb3080e7e53d9fd9e095b819e436b978cd0d
parent906f70406ab6a44d6fadb5d22c43d86e4944da78 (diff)
downloadguix-4a8b4c25b07eedd1427d8c33c01d0c7d6a0f17b5.tar.gz
gnu: kmod: Install symlinks for 'insmod', 'modprobe', etc.
* gnu/packages/linux.scm (kmod)[arguments]: Add 'install-modprobe&co'
  phase.
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 09d123a08d..3ffe2a4cdd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1273,7 +1273,18 @@ to use Linux' inotify mechanism, which allows file accesses to be monitored.")
        ("zlib" ,guix:zlib)))
     (arguments
      `(#:tests? #f ; FIXME: Investigate test failures
-       #:configure-flags '("--with-xz" "--with-zlib")))
+       #:configure-flags '("--with-xz" "--with-zlib")
+       #:phases (alist-cons-after
+                 'install 'install-modprobe&co
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out"))
+                          (bin (string-append out "/bin")))
+                     (for-each (lambda (tool)
+                                 (symlink "kmod"
+                                          (string-append bin "/" tool)))
+                               '("insmod" "rmmod" "lsmod" "modprobe"
+                                 "modinfo" "depmod"))))
+                 %standard-phases)))
     (home-page "https://www.kernel.org/")
     (synopsis "Kernel module tools")
     (description "kmod is a set of tools to handle common tasks with Linux