summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-07-09 21:24:40 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-07-09 21:34:34 +0530
commit4ac2e09051d2962ee4dd3fe2b19b1b7f8052c567 (patch)
tree38235e034daf13a7b8595f95e5c226e78ed291d6
parent314beace600da453941e01026db7c724d8933a9e (diff)
downloadguix-4ac2e09051d2962ee4dd3fe2b19b1b7f8052c567.tar.gz
gnu: go-github-com-golang-snappy: Update to 0.0.4.
* gnu/packages/syncthing.scm (go-github-com-golang-snappy): Update to 0.0.4.
-rw-r--r--gnu/packages/syncthing.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index e40f696720..5cb8449e44 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -404,28 +405,26 @@ processes.")
       (license asl2.0))))
 
 (define-public go-github-com-golang-snappy
-  (let ((commit "553a641470496b2327abcac10b36396bd98e45c9")
-        (revision "0"))
-    (package
-      (name "go-github-com-golang-snappy")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/golang/snappy")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0kssxnih1l722hx9219c7javganjqkqhvl3i0hp0hif6xm6chvqk"))))
-      (build-system go-build-system)
-      (arguments
-       `(#:import-path "github.com/golang/snappy"))
-      (synopsis "Snappy compression format in the Go programming language")
-      (description "This package provides a Go implementation of the Snappy
+  (package
+    (name "go-github-com-golang-snappy")
+    (version "0.0.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/golang/snappy")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "004cw699yz3pdpawhjhpa0y94c4w479nw1rf39zj6h6027kpwv2j"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/golang/snappy"))
+    (synopsis "Snappy compression format in the Go programming language")
+    (description "This package provides a Go implementation of the Snappy
 compression format.")
-      (home-page "https://github.com/golang/snappy")
-      (license bsd-3))))
+    (home-page "https://github.com/golang/snappy")
+    (license bsd-3)))
 
 (define-public go-github-com-jackpal-gateway
   (package