summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 13:56:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:15 +0200
commit4ad3d4f337635ac978fe234f8a2a5d7c543ba51a (patch)
tree0bb4812ea67bc9ff76cfa9faa109bced368e2929
parent3f9702144129338ec7c8c37edc7520724b5bf62d (diff)
downloadguix-4ad3d4f337635ac978fe234f8a2a5d7c543ba51a.tar.gz
gnu: Add java-eclipse-core-contenttype.
* gnu/packages/java.scm (java-eclipse-core-contenttype): New variable.
-rw-r--r--gnu/packages/java.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 8ff24f8652..2dfbe0766d 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2527,6 +2527,34 @@ Eclipse.")
 the module @code{org.eclipse.equinox.preferences}.")
     (license license:epl1.0)))
 
+(define-public java-eclipse-core-contenttype
+  (package
+    (name "java-eclipse-core-contenttype")
+    (version "3.5.100")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "org/eclipse/platform/org.eclipse.core.contenttype/"
+                                  version "/org.eclipse.core.contenttype-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "1wcqcv7ijwv5rh748vz3x9pkmjl9w1r0k0026k56n8yjl4rrmspi"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f ; no tests included
+       #:jar-name "eclipse-core-contenttype.jar"))
+    (inputs
+     `(("java-eclipse-equinox-common" ,java-eclipse-equinox-common)
+       ("java-eclipse-equinox-preferences" ,java-eclipse-equinox-preferences)
+       ("java-eclipse-equinox-registry" ,java-eclipse-equinox-registry)
+       ("java-eclipse-osgi" ,java-eclipse-osgi)))
+    (home-page "http://www.eclipse.org/")
+    (synopsis "Eclipse content mechanism")
+    (description "This package provides the Eclipse content mechanism in the
+@code{org.eclipse.core.contenttype} module.")
+    (license license:epl1.0)))
+
 (define-public java-commons-cli
   (package
     (name "java-commons-cli")