summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-09-19 23:27:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-09-19 23:28:03 +0200
commit4b3b2e63007acee9e3a8c2ea728190480d092c3c (patch)
treebd971c2aaa86dc242fdc2983d447a5c51bad5625
parentc5cf47ccffd9343c30a4a957aa8cb27e218acfe4 (diff)
downloadguix-4b3b2e63007acee9e3a8c2ea728190480d092c3c.tar.gz
gnu: Add python-tibanna.
* gnu/packages/web.scm (python-tibanna): New variable.
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e9c6f1443c..980663fae9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4863,6 +4863,36 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
     (license (list license:bsd-2           ; source code
                    license:freebsd-doc)))) ; documentation
 
+(define-public python-tibanna
+  (package
+    (name "python-tibanna")
+    (version "4.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "tibanna" version))
+              (sha256
+               (base32
+                "185jr5b1dfgh82xcjal0y9wbzds37s0yhx0hp8awlvw26v72awv2"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; Tests require AWS credentials and access to the internet.
+     (list #:tests? #false))
+    (propagated-inputs
+     (list python-benchmark-4dn
+           python-boto3 python-botocore
+           python-lambda-4dn python-tomlkit))
+    (native-inputs
+     (list python-poetry-core
+           python-pytest
+           python-pytest-cov
+           python-pytest-mock))
+    (home-page "https://github.com/4dn-dcic/tibanna")
+    (synopsis "Tibanna runs portable workflows on the AWS Cloud")
+    (description
+     "Tibanna runs portable pipelines (in CWL/WDL and Snakemake) on the AWS
+Cloud.")
+    (license license:expat)))
+
 (define-public guix-data-service
   (let ((commit "1c7539418743e0dfe3a9cad22c414fd732daef8f")
         (revision "42"))