summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-10-27 00:38:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 13:54:18 +0200
commit4b9fa56cadf7442addf22451fc4a7d5a0d34879e (patch)
tree753e84b557443d4d0ca9256f350fe34b0565ab86
parent8e6a9b23d07a3f0cf6f7498ed6d054da8a126a8d (diff)
downloadguix-4b9fa56cadf7442addf22451fc4a7d5a0d34879e.tar.gz
gnu: Add r-baalchip.
* gnu/packages/bioconductor.scm (r-baalchip): New variable.
-rw-r--r--gnu/packages/bioconductor.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3692bb94af..b323541f82 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2293,6 +2293,46 @@ reproducible gene expression signatures capable of accurately distinguishing
 tumor samples from healthy controls.")
     (license license:artistic2.0)))
 
+(define-public r-baalchip
+  (package
+    (name "r-baalchip")
+    (version "1.22.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BaalChIP" version))
+              (sha256
+               (base32
+                "02qwk9n2fyg5f9xxjiiha9mi6p9ii3zi5x7w84sh5d5g58s27g6q"))))
+    (properties `((upstream-name . "BaalChIP")))
+    (build-system r-build-system)
+    (inputs (list perl)) ; extra/get.overlaps.v2_chrXY.perl
+    (propagated-inputs
+     (list r-coda
+           r-doby
+           r-doparallel
+           r-foreach
+           r-genomeinfodb
+           r-genomicalignments
+           r-genomicranges
+           r-ggplot2
+           r-iranges
+           r-reshape2
+           r-rsamtools
+           r-scales))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/BaalChIP")
+    (synopsis
+     "Analysis of allele-specific transcription factor binding in cancer genomes")
+    (description
+     "This package offers functions to process multiple @code{ChIP-seq BAM}
+files and detect allele-specific events.  It computes allele counts at
+individual variants (SNPs/SNVs), implements extensive @dfn{QC} (quality
+control) steps to remove problematic variants, and utilizes a Bayesian
+framework to identify statistically significant allele-specific events.
+BaalChIP is able to account for copy number differences between the two
+alleles, a known phenotypical feature of cancer samples.")
+    (license license:artistic2.0)))
+
 (define-public r-biocversion
   (package
     (name "r-biocversion")