summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-27 14:37:20 +0200
committerMarius Bakke <marius@gnu.org>2022-07-27 16:13:37 +0200
commit4c980a2b9af6cc33abb85713a989d55c1e654b9c (patch)
treed89f3b703825b9a69567397d902fbcea263c2c4c
parenta9107f2703d002bbc37c5649c6d5bcf327946d5f (diff)
downloadguix-4c980a2b9af6cc33abb85713a989d55c1e654b9c.tar.gz
gnu: rust-wayland-egl: Add 0.29.4.
* gnu/packages/crates-graphics.scm (rust-wayland-egl-0.29): New variable.
(rust-wayland-egl-0.28): Inherit from it.
-rw-r--r--gnu/packages/crates-graphics.scm26
1 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 7b64c46065..d69a8292de 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2655,20 +2655,20 @@ and load them into WlBuffers as well as obtain the necessary metadata to
 properly display animated cursors.")
     (license license:expat)))
 
-(define-public rust-wayland-egl-0.28
+(define-public rust-wayland-egl-0.29
   (package
     (name "rust-wayland-egl")
-    (version "0.28.3")
+    (version "0.29.4")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "wayland-egl" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1xd7iap0x4sidmy9dv02cdnxjhnbk9li7r7f39x9cg0i8xs50ly6"))))
+        (base32 "0flslbp8q4nv3hcw941vapn3jh6y7glqaqv63h1mjaqnxrlisa43"))))
     (build-system cargo-build-system)
     (inputs
-     (list rust-wayland-client-0.28 rust-wayland-sys-0.28))
+     (list rust-wayland-client-0.29 rust-wayland-sys-0.29))
     ;; For the PKG_CONFIG_PATH environment variable.
     (native-inputs
      (list pkg-config))
@@ -2681,6 +2681,24 @@ WlSurface, which can then play the role of the base surface for
 initializing an OpenGL or Vulkan context.")
     (license license:expat)))
 
+(define-public rust-wayland-egl-0.28
+  (package
+    (inherit rust-wayland-egl-0.29)
+    (name "rust-wayland-egl")
+    (version "0.28.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "wayland-egl" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1xd7iap0x4sidmy9dv02cdnxjhnbk9li7r7f39x9cg0i8xs50ly6"))))
+    (build-system cargo-build-system)
+    (inputs
+     (list rust-wayland-client-0.28 rust-wayland-sys-0.28))
+    (native-inputs
+     (list pkg-config))))
+
 (define-public rust-wayland-protocols-0.29
   (package
     (name "rust-wayland-protocols")