summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:44:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:56 +0300
commit4d6ef7eb2c8159e3ab8bf2e5d490960cd97958d0 (patch)
tree4373ee8ccde8a143ae1a3c7cef61f3a6aed93e3b
parent845be82d03c55d186a0515cb9ba429e593bb177d (diff)
downloadguix-4d6ef7eb2c8159e3ab8bf2e5d490960cd97958d0.tar.gz
gnu: Add julia-xkbcommon-jll.
* gnu/packages/julia-jll.scm (julia-xkbcommon-jll): New variable.
-rw-r--r--gnu/packages/julia-jll.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 4518aaa97f..3ec9ae6269 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1634,6 +1634,46 @@ build tree Yggdrasil.")
     (description "This package provides a wrapper for the x265 video library.")
     (license license:expat)))
 
+(define-public julia-xkbcommon-jll
+  (package
+    (name "julia-xkbcommon-jll")
+    (version "0.9.1+3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/xkbcommon_jll.jl")
+               (commit (string-append "xkbcommon-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1g2gmd3mj1p369kzvrd02ldgr9s712vs9774v1phb59jxlshc0zc"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("artifact\"xkbcommon\"")
+                    (string-append "\"" (assoc-ref inputs "libxkbcommon") "\""))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("libxkbcommon" ,libxkbcommon)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)
+       ("julia-xorg-libxcb-jll" ,julia-xorg-libxcb-jll)
+       ("julia-xorg-xkeyboard-config-jll" ,julia-xorg-xkeyboard-config-jll)
+       ("julia-wayland-jll" ,julia-wayland-jll)
+       ("julia-wayland-protocols-jll" ,julia-wayland-protocols-jll)))
+    (home-page "https://github.com/JuliaBinaryWrappers/xkbcommon_jll.jl")
+    (synopsis "Libxkbcommon library wrappers")
+    (description "This package provides a wrapper for the libxkbcommon library.")
+    (license license:expat)))
+
 (define-public julia-xml2-jll
   (package
     (name "julia-xml2-jll")