summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2023-08-06 17:53:22 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-24 16:44:02 +0100
commit4e238aa2b0e426b951edc5e0276a37169f4473d7 (patch)
treef0fbf2587a53bcf4e7ea7107ca0649b025c20657
parent53761a7602cd545396fd2d6035458742668998c4 (diff)
downloadguix-4e238aa2b0e426b951edc5e0276a37169f4473d7.tar.gz
gnu: Add ruby-fog-core.
* gnu/packages/ruby.scm (ruby-fog-core): New variable.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3b5554bee5..88fc3bd23a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9696,6 +9696,36 @@ native C API.")
     (home-page "https://ruby.libvirt.org/")
     (license license:lgpl2.1+)))
 
+(define-public ruby-fog-core
+  (package
+    (name "ruby-fog-core")
+    (version "2.4.0")
+    (source (origin
+              (method git-fetch)        ; for tests
+              (uri (git-reference
+                    (url "https://github.com/fog/fog-core")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "184vpi81az7raz98652m7d98ikabdl9di37dgal0adr76q57j03c"))))
+    (build-system ruby-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'set-home
+            (lambda _
+              (setenv "HOME" "/tmp"))))))
+    (native-inputs (list ruby-minitest-stub-const))
+    (propagated-inputs (list ruby-builder ruby-excon ruby-formatador
+                             ruby-mime-types))
+    (synopsis "Shared classes and tests for fog providers and services")
+    (description "@code{fog} is a Ruby cloud services library.  This package
+provides shared classes and tests for @code{fog} providers and services.")
+    (home-page "https://github.com/fog/fog-core")
+    (license license:expat)))
+
 (define-public ruby-pry-byebug
   (package
     (name "ruby-pry-byebug")