summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-17 11:48:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-17 11:48:47 +0100
commit4e51d73596e22cb5fea9a86a6fa97d8636a7253a (patch)
tree639121e149912b7e12aa896a5186e67e4c7badca
parent52bc70e42d4da8901d6093b276822e783a76853a (diff)
downloadguix-4e51d73596e22cb5fea9a86a6fa97d8636a7253a.tar.gz
gnu: guitarix: Fix build.
Fixes <https://bugs.gnu.org/34428>.

* gnu/packages/audio.scm (guitarix)[arguments]: Add phase
"fix-boost-includes".
-rw-r--r--gnu/packages/audio.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8471d03aa1..ae0dddeb66 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1375,7 +1375,20 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
        (list
         ;; Add the output lib directory to the RUNPATH.
         (string-append "--ldflags=-Wl,-rpath=" %output "/lib")
-        "--cxxflags=-std=c++11")))
+        "--cxxflags=-std=c++11")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-boost-includes
+           (lambda _
+             (substitute* "src/headers/gx_internal_plugins.h"
+               (("namespace gx_jack" m)
+                (string-append "#include <boost/noncopyable.hpp>\n" m)))
+             (substitute* '("src/headers/gx_system.h"
+                            "src/headers/gx_parameter.h"
+                            "src/headers/gx_json.h")
+               (("namespace gx_system" m)
+                (string-append "#include <boost/noncopyable.hpp>\n" m)))
+             #t)))))
     (inputs
      `(("libsndfile" ,libsndfile)
        ("boost" ,boost)